Important for iOS users


iOS users are required to update to the latest firmware to continue playing graal. Make sure you update to iOS 5 or over.  This will apply to the following devices:

  • iPhone 4 or older
  • iPod 4 or older
  • iPad 1

If you have any devices listed above please check you system software if it is iOS 5 or above.

 

 

3 Comments

Leave a Reply